The Big Update


#21

I only ever got that message with a 32 bit Java.


#22

It worked just downloading the latest Version of the launcher so… I have 86-bit java though


#23

That’d have been revealed sooner if you’d just have posted your logs ;]
All’s well that ends well though.

There’s no such thing as 86bit.
Sounds like you mean you installed the ‘Windows x86’ version of java, which is 32bit.

You’ll probably want to replace with 64bit if your computer can handle it. 32bit java is limited to a maximum of about 3 gigabytes of ram, and generally performs worse for minecraft


#24

As @_Brunokuz said I also didn’t like how server is looking regarding smooth lighting but I knew it isn’t problem in my graphics card so I researched what is causing this and I found that problem is in grass model files (grass.json, grass_base_1.json, grass_base_2.json, grass_base_3.json, grass_normal.json). In all this files “ambientocclusion” is set to false but it should be set to true so please change that so we can have smooth lighting on grass :slight_smile:


#25

Ah thanks for your investigative work! I don’t use the new models in my RP so I’d never have caught that one


#26

I’ve reverted the world to what it was when the update first launched, if you did not save any schems of stuff you’ve built, there is a world save, but I’ll only save stuff if it is a lot of work do redo it.

You may want to wait a few days before continuing building. If there are more bugs, we may have to reset again.

Some fixes:
Fixed decaying leaves
Fixed missing slabs
Fixed missing vanilla paintings

We will be updating the blocks mod fairly soon to fix some other issues:
Fixed water in cauldrons
Fixed using a bucket to fill modded cauldrons with water

RP updates:
@wheellee is fixing some of the bugs that were reported and will be updating the RP soon
Fixed grass not having ambient occlusion
Fix to missing textures
Fix to some broken models (this will be an ongoing fixing process)

On tree leaves, they are fixed, it may just look different. It seems better foliage makes a huge difference in how the trees look.
Here’s 1.7.10 with better foliage


Here’s 1.8

Here’s 1.7.10 without better foliage


#27

Just used the launcher again and the grass is still the same, smooth lighting is on max and it seems to only affect the grass.


#28

Bruno, fresh explained that whee hasn’t updated the RP with the fix yet.


#29

The paintings are still gone i think, is this fixable at all?


#30

Vanilla paintings should be fine now - Fresh confirmed they were loading normally yesterday. The protection plugin is logging everything it blocks, so it’ll be clear if anything that shouldn’t be blocked, is.

However, if they were bibliocraft paintings then no, they’re gone for good.


#31

Is there any way of getting the 2 wide hobbit windows to work? Would be a bit of a disaster if we lost them.


#32

models?


#34

Four serperate glass blocks. The texture is bugged.


#35

We already use four separate glass blocks to do it though Guan.

I guess models will have to be the way forward on this. I’ll talk to Phe about it and drop a request.


#36

Thats what i meant fornad. But the texture is bugged on the four blocks for some reason…


#37

Maybe I should have elaborated as ‘I guess’ seems a negative reaction:

The 1.7 mod had to have a special block that flipped the opposite texture correctly. It was a little bit hacky and only worked for that one special block (this is no longer possible to do in 1.8).
1.8 allows us to achieve the same thing without any code whatsoever (can be applied to any block if needed).

Achieved by tweaking a vanilla block model file, took like 10 minutes:


#38

Not sure if this has been reported yet, but /delwarp doesn’t work.


#39

Yes it does.


#40

I guess I might be mistaken, but wheelee and I both seem to be under that impression. I’ll give it another try today.


#41

Under that impression based on what? ‘It doesn’t work’ ins’t a lot to go off :[