The Big Update


The Big Update


If your launcher is giving you a crash error when you launch the modpack, right click the ‘ArdaCraft Modpack’ on the left and delete files, then redownload the pack.

It’s finally here! The 1.8.9 update for ArdaCraft has come, after a long wait, and much anticipation. We have been working on this update for a long time now, and we have pushed this update live. I would like to give a lot of credit to @dags, who has worked on almost all the major components of this update.

What’s in the update?


  • Moved from Cauldron to Sponge
  • Voxel Sniper currently does not work
  • Async World Edit has been removed
  • NoClip feature ‘press n to enable’
  • Player Badges
  • Some cool chat features like hoverable text and shortened urls
  • Tab list works
  • Biome, and painting wands
  • Warps can now have spaces in them
  • New paintings system, will most likely have a post explaining this
  • New permissions plugin
  • New chat plugin
  • Better dynmap textures, and viewability
  • No-physics is now a per player toggle, you’ll need to type /np every time you log in


  • Moved to 1.8.9
  • Updated all mods to 1.8.9
  • Shaders mod is now apart of Optifine
  • NoClip mod ‘press n to enable’
  • Some new optional mods/features
  • Daflight config can be accessed with the F9 key

Bugs and things to come:

  • We moved to bedrock, and got rid of Essentials
  • Some previous commands that were there may no longer be there, we are adding some more commands and features as we go
  • Discovery warp system
  • At some point we will have something similar to the discovery plugin
  • Voxel sniper is not updated for the current version of sponge, and it looks like the next update won’t be for the current version, we will have to wait till the next sponge api gets released before voxel sniper will work properly
  • The schematic brush is currently not updated to 1.8.9, we may get this back in the future
  • An animation plugin may come in the future
  • A plot world will be added at a later point
  • Lots more custom models in the resourcepack will come in the future
  • New mod blocks can now be added

Do /help in game and use the arrows on the bottom to cycle the pages before asking about commands (you can type /page next if the arrows aren’t working for you.)

If you find a bug or see something that needs improvement, please post in this thread
If you get a crash, or are having trouble with the launcher, post in the support category




You need to install java 8


Still doesn’t seem to work for me.


Same problem here, so this isn’t about not having updated java


@_Brunokuz @Slurmp
post your logs then pls

note, if it still says:

Java is Java HotSpot™ 64-Bit Server VM, version (or

then it is about using outdated java


I just updated my Java using this link: here
And the modpack worked for me, hopefully that helps :stuck_out_tongue:


Got it working, but now minecraft is just stuck in the loading screen


It worked but it looked even worse then without the launcher, so i won’t be using it probably. :stuck_out_tongue:


Getting a better understanding on what your problem was will help us help others that also run into the same problem(s). With that in mind, please could you clarify on:

It worked but it looked even worse.

What looked worse than what?

worse than without the launcher.

What were you using if not the launcher?


There are randomly missing leaves everywhere. It looks like leaf decay was turned on for a while, but I can’t be sure. I suspect the only way to fix it would be resetting the map to what it was when we updated.

People have also noticed missing slabs in Mithlond, and all vanilla paintings have disappeared.


The leaf decay thing is a relatively new bug with Sponge. Will ask them to fix it. I’ll look for a plugin work around for the meantime, or we could just use an older version of Sponge for a bit.

@Freshmilkymilk’ll probably need to rollback the world save to restore affected trees.

Folk should probably save any building they’ve done since Saturday to schematics so their work can be pasted back in again afterwards

edit: looks like the missing slabs are due to some more bad metadata blocks that weren’t cleaned up. We will add some extra rules to the worldfixer app to catch these and convert back to valid metadata values

Not sure about paintings - might be the environment protection plugin being a bit overzealous with it’s blocking of entities - if this is the case, then they’ll be restored when the world is rolled back

edit: seems that it was a case of the protection plugin preventing them from loading. They’re all still saved within the world files, and should now load as normal.


This just doesn’t seem right at all.
And before that, i was using the self install but some connected textures don’t connect while others do.


Looks like you have smooth lighting turned right down.
The right-hand-side of this screenshot has a similar look to yours:

If you haven’t got it turned off, then it might be that your graphics card/integrated graphics can’t render ambient occlusion very well.

(The above screen was taken on my work pc, which is running on an i3’s integrated graphics, which is pretty pants for games)


Aight thx, i’ll take a look at it later today :slight_smile:


Caused by: java.lang.OutOfMemoryError: unable to create new native thread
at java.lang.Thread.start0(Native Method) ~[?:1.8.0_91]
at java.lang.Thread.start(Unknown Source) ~[?:1.8.0_91]
at CrashReporter.onCrashReport( ~[CrashReporter.class:?]
at net.minecraft.crash.CrashReport.func_71502_e( ~[b.class:?]
at net.minecraft.client.Minecraft.func_71377_b( ~[ave.class:?]
at net.minecraft.client.Minecraft.func_99999_d( ~[ave.class:?]
at net.minecraft.client.main.Main.main(SourceFile:124) ~[Main.class:?]
… 6 more
Exception in thread “Client thread” [12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: net.minecraftforge.fml.relauncher.FMLSecurityManager$ExitTrappedException
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.fml.relauncher.FMLSecurityManager.checkPermission(
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.SecurityManager.checkExit(Unknown Source)
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.Runtime.exit(Unknown Source)
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.System.exit(Unknown Source)
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraft.launchwrapper.Launch.launch(
[12:59:07] [Client thread/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraft.launchwrapper.Launch.main(

This is my the end of the log when I try to join, but it just freezes at initializing minecraft and I never get any longer than that


You’re running out of ram. There’s a guide here on how to increase the maximum minecraft is allowed to use.

The ardacraft launcher’s options look slightly different, but there’s a similar field where you can increase it.


I tried With both 3GB an 4GB but I still get the same Message, and if I try more it says it’s too much for minecraft, Could try redownloading the modpack though.


You might’ve installed 32bit java by mistake.
Please could you post a pastebin of your logs - I can only make guesses otherwise.