Java App Quits When Joining Server


I recently re-downloaded the modpack for the 1.19.2 version onto my mac os desktop computer. Everything seems to be working fine, except that when I go to join the server, I get the loading screen for a few seconds, then the “loading world” message changes to “saving word” with the standard Minecraft dirt background, and the application quits. There are no error messages or crash reports. The java crafting table icon in my hotbar changes to a second AT Launcher icon, and when clicked pulls up the AT Launcher window. I have Java 8 installed. My maximum RAM is 8,000+, as instructed in the guide video. I did have some trouble getting AT Launcher installed, as I was asked to allow it to access “System Events”, accidentally clicked “don’t allow”, and had to go back and allow it through System Preferences.

I hope this is enough information, and thank you for your help!

Hey - firstly it’s best to use our Discord support channel as these forums aren’t regularly used anymore.

I would suggest using the Prism launcher to install our modpack and try again.

Hello again!

Sorry it’s been so long, I forgot to respond.

I have tried using the Prism launcher, but it was crashing because Java wasn’t installed. I downloaded Java 5, tried again, didn’t work, realized it was asking for Java 17, downloaded Java 20, tried again, and it still didn’t work. I think the launcher is still somehow drawing from Java 5 and not realizing that I have 20 installed. I haven’t found anywhere to download Java 17.

Today I had another go at the AT Launcher, and this time I noticed the crash message in the Launcher Console. Here’s the link for the logs: ATLauncher Paste

Should I try to uninstall Java 5? Do I need to get Java 17 specifically?

Also, I don’t have a Discord account, so I can’t shift to there. Sorry if this is inconvenient.

Thank you very much for your time and patience.

Delete the Lambda dynamic lights mod


Could you please be more specific? Is this for the AT Launcher or the Prism Launcher? And where would I look to find this mod? I have tried looking around both systems, and I can’t seem to find it.

Thank you!

AT launcher - the mod link is here:

You’ll need to go into \AppData\Roaming\ATLauncher\instances\TheArdaCraftModpack\mods - find it and delete it

I found and deleted the mod, and now I can join the server successfully!
Thank you ever so much for your help!!

Hello again,

I have been experiencing persistent technical difficulties since I rejoined the server. First of all, I’ve been regularly losing the connection to the server, causing me to need to rejoin. (This might just be bad internet on my end, but I thought I should mention it) Second, sometimes I’ll be moving forwards and then suddenly find myself teleported back to where I was a couple seconds ago. This issue is sometimes so persistent as to be inescapable, unless I warp. Finally, (and this is the one that really concerns me) yesterday I suddenly started noclipping through the terrain, and I can’t seem to stop, even after entering the /noclip command. I continue to noclip even when I quit the game and reopen it.

If you can help with any of these, (particularly the last one) I would be very grateful!

The rubberbanding can happen when the server is overloaded, usually because someone using worldedit is working with too large selection sizes.
The Noclip is a mod that we have, you can read all about these things in the guide book you were given upon joining. Or if you didn’t get the book, you can simply type /guide in the chat.
I hope this helps :slight_smile:


I’m sorry, but either my guide isn’t functioning, or I’m really thick. The only category that shows up is the Entry Index, and when I click that, there are “no entries” listed under Chapters. Nothing I’ve typed into the search bar has yielded any results so far.

Thanks for your help, and your patience. :slightly_smiling_face:

He means typing /guide on the server

1 Like