Invalid Maximum Heap Size - user-typo in launch args

Hello, I have recently downloaded the Ardacraft launcher but I cannot get it to work. Whenever I press launch, I get the error “Invalid maximum heap size”. I am running 64 bit java (I think) and no matter what number I set the maximum memory settings in the launcher options, I get the error. Please help! I’d love to build on the server.

I’m no expert, but I think that means the value you’ve set isn’t right, rather than the actual number, check that you’ve not changed something you shouldn’t have in the line.

Please post your logs and your launch arguments

I too have a similar problem here are my logs:

The game is running. Please wait.
Error occurred during initialization of VM
Initial heap size set to a larger value than the maximum heap size
Java HotSpot™ 64-Bit Server VM warning: ignoring option MaxPermSize=256M; support was removed in 8.0
Picked up _JAVA_OPTIONS: -Xmx512M
Process ended with code: 1

Please help I’ve followed instructions from here as well
as is same problem please help

"Initial heap size set to a larger value than the maximum heap size"
Seems like a java version issue. Did you install Java 8?

i believe so i found navigating through the various java downloads quite complicated i will doublecheck

i followed all steps in the video this is the link i believe and i downloaded and installed jre-8u102-windows-x64.exe under the Java SE Runtime Environment 8u102 section did i do this correctly? as it appears i did from the installation video.
something to nite is it says (offline) next to the Windows x64 name for the download is this anything?

This is what solved the other guy’s issue

I changed the maximum memory to 4gb as i have 16gb of ram but i’ve also tried many other amounts as low as 2gb with no change to the problem also i have an amount of 256MB under the PermGen which i did not change not sure if that is default allocation

what should the default setting be?

1Gb of ram usage is the default, if it launches with that setting, it means your minecraft is running on the wrong java version. If it still crashes, well, that changes the issue completely.

iv’e been playing around with the settings and have found no change at all ive changed all fields e.g max/min MB etc and nothing i might try re downloading the launcher

Dags will assumedly help soon

He fixed it by using the launcher.

no logs, no dags ;]