Crash on start up [Picked up _JAVA_OPTIONS]

how did you install the modpack?: launcher and installer (tried both)
have you installed Java 8?: yes, double checked
when does the problem happen?: during launch and in the menus
I can’t seem to getArdacraft working in any way. I tried to install both the launcher and installer version I even tried to install the Ravand version not sure if it is the same though.

Most versions (including the one from this specific crash report) crash on start up. Some crash when I try to turn on the conquest/arda resource pack.

Can anyone help?

For the log that you have provided (presumably when using the launcher), it’s crashing because your game is running out of memory.

You seem to have some odd launch arguments set for it:

Line #111:

JVM Flags: 5 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xms512M -Xmx4096M -XX:MaxPermSize=256M -Xmx512M

As highlighted in bold above, you’ve added the max ram argument a second time, and set the maximum allocation to 512mb.

This is nowhere near enough memory to run modded minecraft (particularly the launcher version of the modpack, as that contains more mods [and more performance draining ones at that]).

You’d have to provide your logs for the installer version of the modpack for me to help with that, but if you’re using the same launch arguments, then that’s likely the problem


I can see that is wrong but how do I remove this argument from the Ardalauncher? It’s not that I did anything on my own here I just went to the launcher option screen and I may have changed some things but there is no way to add a line from here.

I also checked the config.json and no where can I find this second line.

You may have lowered the Maximum Memory (MB) setting. 2048 is probably the minimum you’d want here.

If not that, then you may have manually added the bad argument into the JVM Arguments field.

Both can be found on the first page of the launcher options screen.

If that doesn’t help you might have to ask @Freshmilkymilk as he’s more familiar with the launcher than myself

Max is on 4k and I added no arguments (only thing I changed is the minimum, I believe. Just to see if it would work)

When did you last update your Razer/Synapse drivers?

Sorry what? I don’t own anything from Razer and how should this affect the game?

line 155:

Picked up _JAVA_OPTIONS: -Xmx512M

Basically, something installed on your computer is setting the _JAVA_OPTIONS environment variable to 512mb.
Razer/Synapse used to do this in older versions of their drivers.

You could have a look at your envrionment variables and delete the entry for _JAVA_OPTIONS if it’s there.

If it isn’t there, I can only really suggest you go through all your peripheral drivers (mouse, keyboard, webcam w/e) and make sure they’re up to date.

Doubt we’ll be able to help you beyond the above suggestion I’m afraid, as it’s not a problem with the launcher. You might be able to find help on some sort of tech support forum or stackoverflow maybe

1 Like

It worked seems somehow a variable was added thanks alot!

1 Like

Awesome, thanks for reporting back to us. Certainly an unusual problem so it’s good to know what to look out for and how to fix it in the future